Archivio per la Categoria “Errori”

 

 

 

 

A volte capita/capitava su Debian Squeeze, di trovarsi con l'icona di Network-Manager con una X, per segnalare un problema con la connessione, ma in realtà la connessione c'è, ed è funzionante. Per risolvere il problema:

 

# nano /etc/NetworkManager/NetworkManager.conf

 

e settare a true:

 

[ifupdown]
managed=true

 

riavviare:

 

# /etc/init.d/network-manager restart

 

 

enjoy ;)

Tag:

Comments 7 Commenti »

 

Dopo gli ultimi aggiornamenti su Debian Sid, mi sono ritrovato con questo tipo di errore:

 

Configurazione di desktop-file-utils (0.18-1)…
update-desktop-database: error while loading shared libraries: libpcre.so.3: cannot open shared object file: No such file or directory
dpkg: errore nell'elaborare desktop-file-utils (–configure):
 il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 127
configured to not write apport reports
                                      Si sono verificati degli errori nell'elaborazione
:
 desktop-file-utils
/usr/bin/gdbus: error while loading shared libraries: libpcre.so.3: cannot open shared object file: No such file or directory
E: Sub-process /usr/bin/dpkg returned an error code (1)

 

si risolve con:

 

# cd /lib/x86_64-linux-gnu

# ln -s libpcre.so.2.13.1 libpcre.so.3

 

 

enjoy ;)
 

Tag:,

Comments 3 Commenti »

 

Mentre stavo convertendo con FFmpeg un file da AVI ad AVI, ho avuto questo errore che mi ha fatto perdere un po di tempo:

 

  Metadata:
    encoder         : VirtualDubMod 1.5.4.1 (build 2178/release)
    IAS1            : Italiano
  Duration: 01:24:35.04, start: 0.000000, bitrate: 1155 kb/s
    Stream #0.0: Video: mpeg4 (Advanced Simple Profile), yuv420p, 608×256 [PAR 1:1 DAR 19:8], 25 tbr, 25 tbn, 25 tbc
    Stream #0.1: Audio: ac3, 48000 Hz, 5.1, s16, 384 kb/s
[buffer @ 0x6d7f80] w:608 h:256 pixfmt:yuv420p
[scale @ 0x6d1460] w:608 h:256 fmt:yuv420p -> w:352 h:288 fmt:yuv420p flags:0×4
Output #0, avi, to 'Braveheart-cd1.avi':
    Stream #0.0: Video: mpeg4, yuv420p, 352×288 [PAR 171:88 DAR 19:8], q=2-31, 200 kb/s, 90k tbn, 25 tbc
    Stream #0.1: Audio: libmp3lame, 48000 Hz, 5.1, s16, 200 kb/s
Stream mapping:
  Stream #0.0 -> #0.0
  Stream #0.1 -> #0.1

Error while opening encoder for output stream #0.1 – maybe incorrect parameters such as bit_rate, rate, width or height

 

si risolve abbassando la frequenza, da 48000hz a 44100hz, e forzando per la scelta di 2 canali:

 

$ ffmpeg -i input.avi -acodec libmp3lame -ar 44100 -ac 2 -vcodec copy output.avi

 

la cosa interessante di questo downgrade audio, è che si ottiene un video più compresso, senza una significativa perdita, per un uso normale. Nel mio caso il film era di 1,5G ed è sceso ad 1,2G, e questo mi ha permesso di mettere i 4 film che volevo su un unico dvd, cosa che prima con i 4,8G totali, non potevo.

 

enjoy ;)
 

Tag:

Comments 1 Commento »

 

Dopo aver fatto pulizie di tutte le estensioni, poichè ne avevo di "vecchie e doppie", tanto da non capire quale mi davano problemi, mi sono rimesso a reinstallarle. L'estensione Dock a sinistra per me è obbligatoria, quindi come al solito sono andato a modificare GSettings, ma la Dock mi rimaneva sempre a destra. Leggendo attentamente, ho letto che nella versione di Gnome 3.2, adesso bisogna modificare a manina il file extension.js, mentre nelle versioni 3.3 e 3.4, tutto viene memorizzato in GSettings. Nel file extension.js ci sono 12 RIGHT, il primo va tenuto:

 

const PositionMode = {
    LEFT: 0,
    RIGHT: 1
};

 

gli altri 11 dovranno diventare LEFT.

 

Update 13/2:

adesso va con il comando solito….mah!!!!

 

$ gsettings set org.gnome.shell.extensions.dock position left

 

 

enjoy ;)

Tag:, ,

Comments Nessun Commento »

 

Questo tipo di errore, "modprobe: module unix not found in modules.dep" appare nelle primissime righe al boot, su Debian Wheezy e Sid. E' un errore che non comporta nessun malfunzionamento del nostro O.S. ma visivamente sta male. Quindi per risolvere la situazione basta:

 

# nano /usr/share/initramfs-tools/hooks/udev

 

commentare la riga:

 

# force_load unix

 

e poi:

 

# update-initramfs -u

# init 6

 

Solved.

 

enjoy ;)

Tag:,

Comments 6 Commenti »

 

                                Errore di lockdown non gestito (-15)

 

Quella sopra è la classica finestra di errore che si ha, quando si cerca di montare l'Iphone, ed in particolare dopo l'aggiornamento ad IOS 5.0.1. Io ho aggiornato ad IOS 5 da circa un mesetto, e da allora ho avuto questo tipo di problema, ma stasera mi sono deciso a risolvere la situazione, dato che mi serviva un video che avevo all'interno.

 

Soluzione:

 

# apt-get install ifuse libimobiledevice-utils

 

Collegare l'iphone e poi digitare i seguenti comandi:

 

$ idevicepair unpair && idevicepair pair

 

se tutto sarà andato bene apparirà qualcosa di simile:

 

edmond@Debianbox:~$ idevicepair unpair && idevicepair pair
SUCCESS: Unpaired with device ecf38c1931fa4c53d11a0e188527ef913cdef838
SUCCESS: Paired with device ecf38c1931fa4c53d11a0e188527ef913cdef838

 

scollegare  e ricollegare l'iphone, e subito verrà montato automaticamente.

 

 

enjoy ;)

Tag:,

Comments 10 Commenti »

 

L'errore su Virtualbox che ho avuto sull' Acer Aspire One:

 

Apertura di una sessione per la Macchina Virtuale non riuscita: VT-x features locked or unavailable in MSR. (VERR_VMX_MSR_LOCKED_OR_DISABLED).
Codice 'uscita: NS_ERROR_FAILURE (0×80004005)
Componente: Console
Interfaccia: IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}bilitare

 

si risolve deselezionando la voce " Abilita VT-x/AMD-V  ", nel menu Sistema-Accellerazione, ed anche portando il numero delle cpu a 1.

 

enjoy ;)
 

Tag:,

Comments 5 Commenti »

 

 

 

 

Se capita di avere problemi col riavvio in Debian, ora sapete con chi prendervela :). Ultimamente per una questione di tempo, ho installato Debian Squeeze da un Live CD, e di conseguenza mi sono ritrovato con il problema di non riuscire, una volta riavviato, a vedere gli altri O.S. nel menu di Grub. Tutto questo per opera di kexec-tools, questo pacchetto fornisce strumenti per caricare in memoria un kernel e poi "riavviare" direttamente in questo kernel tramite la chiamata di sistema
kexec, bypassando il normale processo di avvio.

 

# apt-get remove --purge kexec-tools

 

enjoy ;)

Tag:

Comments 1 Commento »